Back to overview
Downtime

Major Provider Outage affecting all Faraday Services

Jun 23 at 01:38pm EDT
Affected services
teamfaraday.com
Server Status

Resolved
Jun 23 at 03:00pm EDT

The incident has been resolved.

Updated
Jun 23 at 02:13pm EDT

We're still investigating the incident. Our provider has been notified.

Created
Jun 23 at 01:38pm EDT

We are currently aware of a network-wide outage affecting all Faraday services. Appropriate units have been notified.